配置文件现在需要绝密的短语密码(blowfish_secret)

时间:10-03-03 栏目:网络&技术 作者:wukong 评论:0 点击: 1,342 次

解决:配置文件现在需要绝密的短语密码(blowfish_secret)问题2009年05月07日 星期四 14:53问题:在登录phpmyadmin时,有时会出现“配置文件现在需要绝密的短语密码(blowfish_secret)”这样的错误提示。解决方法:到phpmyadmin的安装目录里面找到config.inc.php文件,用记事本将其打开,通过记事本的查找功能查找“$cfg['blowfish_secret']=’ ‘”语句。在其单引号里面随便输入一些数字或字母(默认为空),最后保存。再到phpmyadminlibraries目录下找到config.default.php文件。对其进行通用的操作。完成以后重启IIS或Apache,登录phpmyadmin也许之前的错误提示仍然存在,但重新选择某种语言后就可以了,进去后再在页面的右上角选回自己想要的语言类别。总结:出现这样的错误,原因在于我们将config.inc.php和config.default.php里面的$cfg['Servers'][$i]['auth_type']设置为cookie(默认为config,但这样不是很安全,所以有必要改为cookie)而$cfg['blowfish_secret']却是空的。既然将$cfg['Servers'][$i]['auth_type']设置为cookie,那么就应该通过某个cookie来访问它,这正是通过$cfg['blowfish_secret']来设置。所以$cfg['blowfish_secret']不能为空。

声明: 本文由( wukong )原创编译,转载请保留链接: 配置文件现在需要绝密的短语密码(blowfish_secret)

配置文件现在需要绝密的短语密码(blowfish_secret):等您坐沙发呢!

发表评论

您必须 [ 登录 ] 才能发表留言!

------====== 本站公告 ======------
大家有任何疑问和建议,请到这里留言:点击留言板

读者排行